読者です 読者をやめる 読者になる 読者になる

GeekFactory

int128.hatenablog.com

IX2015に移行しました

自宅サーバ

自宅のルータを PLANEX BRC-14VG から NEC IX2015 に移行しました。BRC-14VGは実家に移設してIPSecルータとして使う予定です。まだまだ現役。

PLANEX VRRP対応セキュアストレージ BBルータ BRC-14VG

PLANEX VRRP対応セキュアストレージ BBルータ BRC-14VG

IX2015のconfigを貼り付けておきます。こうした方がいいよっていうのがあったら、ご指摘をお願いします!

hostname gw
timezone +09 00
!
syslog facility kern
syslog ip host 172.16.3.32
syslog ip source 172.16.3.254
!
username root password hash ******** administrator
!
ntp ip enable
ntp server 210.173.160.27
ntp server 210.173.160.57
ntp server 210.173.160.87
ntp interval 7200
!
logging buffered 1048576
logging event-delay startup 60
logging subsystem all error
logging timestamp datetime
!
ip ufs-cache enable
ip route default FastEthernet0/0.1
ip route 172.16.32.0/19 172.16.3.32
ip route 172.16.64.0/19 172.16.3.32
ip route 172.16.192.0/19 172.16.3.32
ip dhcp enable
ip access-list manage permit ip src 172.16.3.0/24 dest any
!
proxy-dns ip enable
!
telnet-server ip enable
telnet-server ip access-list manage
!
ppp profile isp
  authentication myname ***@***
  authentication password ***@*** ********
!
ip dhcp profile homenetwork
  assignable-range 172.16.3.170 172.16.3.199
  dns-server 172.16.3.32 172.16.3.254
  domain-name ********
  fixed-assignment 172.16.3.140 **:**:**:**:**:**
  fixed-assignment 172.16.3.150 **:**:**:**:**:**
!
interface FastEthernet0/1.0
  no ip address
  shutdown
!
interface FastEthernet1/0.0
  ip address 172.16.3.254/24
  ip dhcp binding homenetwork
  no shutdown
!
interface FastEthernet0/0.1
  encapsulation pppoe
  auto-connect
  ppp binding isp
  ip address ipcp
  ip tcp adjust-mss auto
  ip napt enable
  ip napt service http 172.16.33.1 none tcp 80
  ip napt service https 172.16.34.1 none tcp 443
  ip napt service ssh 172.16.36.1 22 tcp ***
  ip napt service openvpn 172.16.36.1 none tcp ***
  ip napt service rdp 172.16.67.1 3389 tcp ***
  no shutdown